Degraded Performances
Incident Report for Activix
Resolved
This incident has been resolved.
Posted Mar 13, 2024 - 16:30 EDT
Investigating
We are seeing degraded performance affecting the CRM. Communications are delayed. Our team is investigating the problem.
Posted Mar 13, 2024 - 13:29 EDT
This incident affected: CRM, Phone System, and NioText.