Degraded performance of the CRM
Incident Report for Activix
Resolved
This incident has been resolved.
Posted Aug 22, 2022 - 21:18 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 22, 2022 - 13:39 EDT
Investigating
We are seeing degraded performance affecting the CRM. Our team is investigating the problem.
Posted Aug 22, 2022 - 10:06 EDT
This incident affected: CRM and Phone System.