Degraded performance of the CRM
Incident Report for Activix
Resolved
This incident has been resolved.
Posted Nov 15, 2022 - 17:52 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 15, 2022 - 17:42 EST
Investigating
We are seeing degraded performance affecting the CRM. Our team is investigating the problem.
Posted Nov 15, 2022 - 17:29 EST
This incident affected: CRM and Phone System.