Degraded Performance
Incident Report for Activix
Resolved
This incident has been resolved.
Posted Mar 22, 2024 - 07:40 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 21, 2024 - 18:10 EDT
Investigating
We are seeing degraded performance affecting the CRM. Communications are delayed. Our team is investigating the problem.
Posted Mar 21, 2024 - 15:03 EDT
This incident affected: CRM, Phone System, and NioText.