Degraded performance of the CRM
Incident Report for Activix
Resolved
This incident has been resolved.
Posted Aug 25, 2022 - 18:37 EDT
Investigating
We are seeing degraded performance affecting the CRM. Our team is investigating the problem.
Posted Aug 25, 2022 - 17:22 EDT
This incident affected: CRM and Phone System.