Degraded Performance
Incident Report for Activix
Resolved
This incident has been resolved.
Posted Mar 11, 2024 - 20:17 EDT
Investigating
We are seeing degraded performance affecting the CRM. Communications are delayed. Our team is investigating the problem.
Posted Mar 11, 2024 - 14:20 EDT
This incident affected: CRM and Phone System.