Phone provider is having issue
Incident Report for Activix
Resolved
This incident has been resolved.
Posted Apr 12, 2023 - 13:02 EDT
Investigating
Our main phone provider is experiencing some issues right now. SMS delivery and phone recording are impacted. We are monitoring the situation with them.
Posted Apr 12, 2023 - 11:35 EDT
This incident affected: Phone System.